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This eBook is free to download and distribute. The content of the eBook is 
not copyrighted and may be used freely by anyone without prior permission
of the author. The author requests a recommendation or a back link in such 
cases..Peace!

The eBook is a collection of amazing things that the player VLC Media 
Player can do. All the techniques are tried and tested by me on a 32-Bit 
Windows 7 Ultimate System. But the author takes no responsibility of any 
kind of damage caused by any of the techniques mentioned in the book. 

The eBook is designed to appeal to the average PC user, and I'm sure that 
most of the readers would be able to appreciate the power of VLC after 
reading this book.

There is no relation between the author and the team at VideoLan. The 
author has not been paid in any kind to endorse or publicize anything. This 
project is a tribute to the application which has been making our lives 
simpler for years!

http://www.twitter.com/thesidjway


The Intro

VLC is an acronymn for Video LAN Client. It is a very popularly known free 
media player that is available for all major platforms like Windows, Mac OS 
X, Linux, BSD, Solaris, Android, iOS and many more. It all started off as a 
development educational project by students at the École Centrale Paris 
(Which is a top level French institution in the field of engineerning) which 
has grown up to become a phenomenon in the world of media players, 
music, multimedia, internet and humanity!

Video LAN Client was named so because it was developed as a user tool for
accessing VideoLAN, which itself was a protocol to create and share over a 
Local Area Network (LAN). But today, calling it just a client would be 
considered a joke. 

After a complete rewrite in 1998, it became Open Source, thanks to the 
agreement of the École Centrale Paris, in 2001. The project then started to 
open up to developers outside of the École. It is now a worldwide project 
with developers from 20 countries.

Since 2009, the project is completely separated from École Centrale Paris, 
and is backed up by an autonomous non-profit organization. The current 
President of the VideoLAN non-profit organization which maintains the 
project's website is Jean-Baptiste Kempf, who is also one of the project's 
developers. 

VLC today has become a synonym to stability, customizeability and speed, 
all put together in one neat media player package that plays almost any 
media file format you throw on it! That's the VLC Magic. But there's more. 
And the next section of the book is dedicated to that!



Why VLC Media Player?

You have a right to ask why? When you have the mighty ol' Windows Media
Player that comes pre-loaded on a Windows system, or players like Banshee
and Rhythmbox on Linux systems or just QuickTime, then why do you have 
to download another player that does not look as sleek and suave as any of 
these players?

The fact is that, out of the box, VLC has many more features than the other 
players. The size of the install may not be large, but when you go through 
this eBook and get to find out what all VLC can do out of the box, you'd be 
biting your nails!

The key features of VLC Media Player that make it irresistible are:
• It'd play anything! MKV, OGG, ASF, MOV, FLAC.... You name it! It also 

tries to play broken and corrupted files and is quite good at doing 
so. You can even watch a video as it is being downloaded over a P2P 
network like BitTorrent!

• It's fast. Yes indeed it is. No appreciable lag between double-clicking 
on a file and VLC Media Player playing it. It feels responsive and 
smooth even on old systems.

• It is very easy to customize it. You can find hundreds of addons and 
themes for VLC, that can make it even more powerful than it really is.

• It is open source, so anyone can customize the player for a version 
more suitable for his use. For example if a guy is a music aficionado, 
he may add several addons to the player for making his music 
listening experience great, while not compromising on the ability to 
play video. That's the power of VLC and all open source software in 
general.

• It is regularly updated. The VideoLAN team is very hard working and 
rolls out new features and updates with every single release 
(although increasing the size!).

• It's FREE! Best of all, you don't have to shell out a single buck for 
making the player yours!



The Interface

As you can appreciate, the interface is clean and non confusing. Any person 
who has operated any other media player will feel right at home with the 
buttons. People may find it boring and dull, but they can always customize 
it the way they want it to be!
For an example, take a look at this customized VLC Media Player (courtesy 
ReksVeks on DeviantArt). Nice, ain't it?



Playing a Media File

On Your PC:
• Go to Media>Open File and browse to the location of the File. 

Alternatively you can press Ctrl+O to do that.
• If the default player for media files is set as VLC, just double click on 

the file to play it.
• If not, you can right click on a file and select the application with 

which you want to open it. Select VLC Media player and you're good 
to go.

From a CD/DVD/Blu-Ray Disk
• Go to Media>Open Disk and select the drive in which the Disk is 

inserted. Alternatively, you can also press Ctrl+D to do that.
• In the AutoRun menu that appears after you load a disk in the drive, 

there should be an entry for playing with VLC Media Player.
From the internet

• If you have a direct link to a media file on the internet, then go to 
Media>Open Network Stream. Alternatively you can also press 
Ctrl+N to do that. For example:

• But the fact is that most videos on the internet are not files like .mpg 
or .mp4. Most videos on the web are flash based, and the most 
popular website for flash videos is undoubtedly YouTube. VLC 
supports YouTube videos too. Just paste the YouTube link of the 
video to play it seamlessly. Also worked for DailyMotion. The 
playback is very nice on a 2Mbps connection, without stutters! Here 
is an example of a video from YouTube playing seamlessly on a VLC 
Media Player



• VLC can also play Live RTMP streams (For watching Live TV on your 
PC). It needs a bit of configuration. I have covered the same in the 
later sections of the book.

• VLC itself has a nice library/repository of internet radio stations and 
TV stations that you can play. To access them go to View>Library and
in the side bar, you'd see Internet and a large collection of playable 
channels. Double Click on one of them and enjoy!



• VLC also has a repository of Jamendo tracks. If you don't know what 
Jamendo is, it is a service that allows upcoming musicians to share 
their music for free. So you get to listen to new music for free, and 
some of the stuff over there is really nice. Many musicians have made
it big after Jamendo. The Jamendo radio has its own section in the 
Internet section of the library, with option to play only the best tracks
or the radio categorized according to genre. It is a great artist 
discovery service, all for free.



The Equalizer

The player comes with a built in virtual equalizer. Equalization is the process
of adjusting the balance between frequency components within an 
electronic signal. Most modern players have this feature incorporated in 
them. And VLC is no exception. To start the equalizer you can simply click 
the        button in the player. If you're like me and don't know much about 
the stuff like Bass, Treble, you can simply select an equalizer from the 
presets classified according to Genre. So if you're playing Rock music, simply
select Rock as the equalizer preset and get ready for better head banging! 
Experiment around with the sliders to get a setting that suits your taste of 
music the best!

In the same way you can also play around with Compressor and Spatializer 
the same way (Honestly I don't know what these words mean!).



Manage Playlists

Playlists are essential for all kinds of music categorization. Almost all players
today come with options for playlists, so does VLC Media Player. 

• To Create a New Playlist, Go to View>Playlists. Or press Ctrl+L
• Right Click on the Window that opens and select options to add Files

or Folders to the playlist you want to create. You can also drag files 
and folders to the location to do the same.

• Now you have to save the playlist. To do this, either go to 
Media>Save Playlist to File or simply press Ctrl+Y. Select the name of
the file and the format. The M3U format is most commonly used for 
playlists, but you can choose other formats too.

• You can have multiple playlists and these playlists are cross-platform 
and cross-player too (I hope you understand what I mean to say). 
You can have separate playlists for Rock Music, Soul Music and Music
to listen to while on jogs. It's your world!

• You can also add Videos and Network Stream to the playlist. It can be
done by Right clicking in the playlist area and selecting Advanced 
Open. Now you have to do what you did earlier to play online media 
files.



Convert Media

Not many people know this, but VLC can act as a nice converter for media 
as well. It supports input in all formats of media files that it supports (A 
plethora of them!) and can output in MP4, OGG, AVI, MP3 etc.

• Go to Media>Convert/Save or alternatively press Ctrl+R
• Add the file you wish to convert by navigating to the folder that 

contains it. You can choose to add a subtitles file as well, which is the
option right below the media addition window.

• Now Click on Convert/Save and then in the window that appears, 
you have to choose one of the presets for the conversion. Select a 
format for conversion to. You can even convert a video to an audio 
file. You can even edit the Bitrate, the Sample Rate etc. by pressing 
the      button next to the format selection dropdown. Lower down 
the Bitrate for a smaller file size, or you may change the resolution of
a video. For example, you may convert a 1080p video to a 720p 
video, thus reducing its file size and saving you valuable space on 
your HDD. You can also choose the format and then go through the 
settings for the codecs that give you the best outputs. When you're 
happy with the settings, just name the file in the box that is below 
the format dropdown, and let the conversion begin. I've seen that 
the conversion speeds are not much slower than dedicated media 
conversion software



There is no need for another conversion software when you have the gem 
called VLC!



Adjust Video Settings

VLC allows control over your playback like no other player. Just open your 
video and you can add a lot of effects to it without any extra addons.

• Open a Video in VLC
• Go to Media>Effects & Filters or Press Ctrl+E. Alternatively, press the 

equalizer button described earlier. Go to Video Effects Tab
• Now have fun. You can crop, change colours, add hue, adjust 

gamma, rotate the video, add blur, adjust contrast and much more. 
Tweak with the settings to get an optimal result with your video. You 
may choose to have high contrast for making a horror movie scene 
more grim, or add hue to a nature video to make it more enjoyable.

• Once done, exit the window opened, and the video will play with 
new settings. To undo the change, simply uncheck the boxes 
associated with the different video effects. Here I am posting a video 
snapshot before and after adding effects 

 Before

 After



Download YouTube Videos

VLC also acts as a nice way to download YouTube videos. No plugin 
required!

• You first ought to have the URL of the YouTube video. Copy it to your
clipboard

• When in VLC Media Player, press Ctrl+N or go to Media>Open 
Network Stream. In the Window that opens up, paste the URL of the 
YouTube video. Hit Enter. You'll observe that the Video starts playing 
on the player

• Now go to Tools>Media Information or press Ctrl+I. In the lower part
of the window that opens, there will be a TextBox called Location.

• Copy the text of the Location TextBox and paste it in your download 
manager (Like FDM) or simply your browser. You'll see a file gets 
downloaded which has no extension. Rename the file to a name with 
the extension .flv . The Video has successfully been downloaded!

Kindly be considerate to the amount and efforts artists put in to make 
music. Kindly buy a song if you like it. Please don't download copyrighted 
videos!



Fun with Videos

Taking Snapshots
If you wish to take a screenshot of the video, sans the player, just go to 
Video>Snapshot. The file is saved in the Pictures library in png format. And 
yes, its the same image as above!

Video As Wallpaper
We have seen wallpapers getting interactive, but how about a video playing
as a wallpaper? Seems crazy, doesn't it? But VLC can allow you to have the 
fun. Just go to Video>Set As Wallpaper. Well the feature is silly and has no 
use. No icons are visible on the desktop and the wallpaper is removed as 
soon as the player is stopped. It is just like VLC playing a video in full screen,
nothing else.



Videos in ASCII
Have you ever seen an ASCII art video? They were popular in the late 80s in 
which a video was made using text characters only. You can experience it on
VLC too. Just go to Tools>Preferences and select Video tab. In the output 
section select Colour ASCII Art and now play your videos to see the fun. Of 
no practical use though!

Puzzle Game
If you've already noticed this feature, you are a curious, inquisitive fellow. If 
you've not, try it by going to Video Effects after pressing Ctrl+E. Then go to 
Geometry tab and select puzzle game. Select no of rows and column and 
exit. Now your video has turned into a jigsaw puzzle that you can assemble 
to make a video! And the best part, the video keeps playing as you solve 
the puzzle! Great fun!



Add a Logo or text to your Video
You can do it in the overlay section in the Video Effects window. You can 
also add a text to the video. Bad part is that you can't edit the font!



Play a Video Stream from a WebCam

With VLC you can play a video live stream from a WebCam. To do this go to 
Media>Open Capture device. Connect your WebCam before doing this. 
Now select your device from the dropdown for both Video & Audio input. 
You should have the video up and running in a few seconds. In my case, I 
found a bit of a lag. That may be due to the fact that I still own a 10 yr old 
WebCam, but it may be perfect for you. Drop in a comment if it works for 
you! You can record the video from the software itself! In the next section, 
you will know how!



Record Videos, Radio, Podcasts etc.

For doing this, you simply go to View>Advanced Controls. Now you'd see a 
big red button along with a few new buttons. Now whatever you are 
playing, you can record it. When you have to start recording, press the red 
button once, and when you're done, press it again. Just like the snapshots 
stuff, it is saved in the Videos Library.

Please note that recording radio is not recommended. You are causing 
monetary harm to a singer if you're recording his/her song. If you like a 
song, just buy it! Feel free to record podcasts! Now you can also record the 
output from your WebCam!



Scrobble to Last.FM

Many people use Last.FM as a very nice music discovery service that gives 
users personalized radio according to the tastes of the user. But for 
recognizing the tastes of the users, it should know what type of music do 
they listen. So scrobbling refers to sending data about played tracks to 
Last.FM. 
To do so, for other media players, you have to download a plugin or install 
it via the Last.FM PC software. No such worries in VLC as VLC has Last.FM 
support built in!
Just Go to Tools>Preferences>Audio and tick Submit played tracks stats to 
Last.FM checkbox. Enter your username and password and done! Whatever 
tracks you play are scrobbled to Last.FM and you can enjoy personalized 
radio with that!

Me on Last.FM---> www.last.fm/user/thesidjway 

http://www.last.fm/user/thesidjway


Make VLC Look the way you want to be!

Change Button Placement
You can change the default button placement in VLC by going to 
Tools>Customize Interface...
You can change the position of the toolbar, or change the order of buttons 
on it, or add new buttons too!

Change the Skin
Go to Tools>Preferences>Interface and select 'Use custom skin” from there. 
Now you have to download the theme files for VLC. They are available in the
.vlt format. A lot of skins are available on the official website 
http://www.videolan.org/vlc/skins.php. The skins are available for single 
download or they also have a 37MB archive that has all the skins. Now you 
have to place the themes in the skins directory of your player. For example if
you have VLC installed at 'D:\VLC Media Player', then you should copy all 
themes to 'D:\VLC Media Player\skins'.
Now when you restart VLC, you will notice a new interface which is the 
default skinned interface of VLC. Now to change the theme, right click in the
main window, go to Interface>Select Skin>Your Theme. If you've done 
everything right, VLC would now be looking entirely different. Here's a 
screenshot of one of my favourite themes.

http://www.videolan.org/vlc/skins.php


More Techniques

Play from archives
VLC Player can play compressed video files also. Video will play as a normal 
video and you can also use the seek bar as well. Sometimes the .rar file is 
broken into several parts but with VLC player its not a problem. What you 
have to do is that just load the first part (e.g. .part001.rar ) and it will 
automatically take the rest of the parts and play the whole file.

Record Your Desktop
In VLC, go to Media>Open Capture device. Now in Capture mode select 
Desktop. Initially you'd see a very peculiar display of infinite screens of VLC. 
Now what VLC is doing is playing what you see on your desktop, and now 
you can understand why you see infinite screens. Now to record your 
desktop, select Advanced Controls as described earlier. Now you should 
press the big red button. Now record your desktop the way you do it with 
dedicated software. After you're finished, just press the red button again. 
You'd have to edit the video slightly to cut out the start and the end, to hide
the VLC.



Subtitles in VLC

VLC supports subtitles natively. You just have to navigate to the subtitles 
files. Subtitles are available for almost all music videos and movies out 
there. To navigate to the subtitles file, go to Subtitle>Add Subtitle File.. The 
most common format used is .srt. 

Sometimes there is a delay in the timing of the video and the subtitles file. 
That can easily be corrected. The keys for this are 'h' and 'g' respectively. So 
you can watch a movie without knowing the forthcoming dialogues in 
advance or wondering 'what the hell did the chap say?'!



Keyboard Shortcuts 

Become a keyboard VLC warrior with these keyboard shortcuts that'll make 
the player easier to use!

F: Full Screen 
Space: Play/Pause 
T: Show Position/Time 
S: Stop 
Ctrl+Q: Quit
+/-: Faster/Slower
N/P: Next/Previous 
Ctrl+up: Volume Up 
Ctrl+down: Volume Down
Ctrl+E: To Adjust Audio/Video Effects
Ctrl+ H: To Hide/Unhide Controls
M: Mute
Z: Zoom In
Shift+Z: Zoom Out
Ctrl+Right/Left: To Skip a minute in the Audio/Video
T: Check remaining Time in Video
Ctrl+O: Open Single File
A: Change Aspect ratio
Shift+S: Capture Snapshot 
Shift+R: Record Video



Watching Live TV on your PC

With people getting access to high speed broadband and 3G, Internet TV 
has become a possibility. Live TV is available online on many servers, but 
they are usually crappy and show up a lot of advertisements in the 
surroundings of the play area. But with VLC, you can watch Live TV on your 
own desktop, just like you'd on a HDTV in your couchroom.

This is possible with the help of a software known as RtmpGUI. It defines 
itself as a GUI version of rtmpdump, a toolkit for RTMP streams. All forms of
RTMP are supported, including rtmp://, rtmpt://, rtmpe://, rtmpte://, and 
rtmps://.

rtmpGUI has an extensive list of thousands of channels from almost all 
countries in hundreds of languages! Everything from HBO to Discovery to 
Fox Sports is covered. And all these can be streamed free from your system. 
I don't know about the legality of the streaming but it just works!

For configuring RtmpGUI, you first have to download the portable 
application. It's under a Megabyte, so won't take much time. During 
installation it will load the channels list, which may take a few minutes.  
There are thousands of channels from almost every country and in 
hundreds of languages.  The program should automatically find your VLC 
location and add it as the default media player.  If it doesn’t then click “File” 
and then “Options” and either enter the path manually or click “Locate” to 
browse for it. 



Now simply double click on the required channel to play it in VLC. You'd 
find out that only about half the channels actually work well, some work 
with no audio, some with no video, some with a lot of lag. So try out the 
channels well and you'd probably get to watch quality TV on your PC for 
free!

Download Link for RtmpGUI

https://rtmpgui.googlecode.com/files/rtmpGUI_v18.zip


Extensions for VLC

VLC Media Player is capable of doing much out of the box. But there are 
certain extensions that when incorporated in VLC make it even a better 
player to use!

Here is a list of a few of them that all VLC users should install.

VLSub
It searches and downloads subtitles from opensubtitles.org using the hash 
of the video currently playing or its title. Very useful extension to carry out 
subtitling tasks. I was not able to test this one out on my latest VLC 2.1.3 as 
according to its page, it has stopped working above VLC 2.0.8 on Windows. 
If you own an older version, do install this extension.

Song Teacher
This extension helps you to learn the lyrics of of your favorite songs. There 
are a few glitches but this mostly depends on the source file, not the 
extension. You won't get any error with properly tagged files. The most 
important thing is that you can actually sing along with the music, and VLC 
will show you the right lines with green and mark the ones where you made
mistakes with red. This color coding is really helpful in learning song lyrics.





Tag your Files

Many file formats support tagging of the audio/video. I personally am a 
mp3 tag freak. All the songs in my collection are tagged. If you don't know 
what tagging is, it is adding metadata to the file that makes it easier to find 
out in any kind of media player, on phones, tablets or on PCs. I also like all 
my songs with their album art on. You can do all this in VLC Media Player. 
Just when a song/video is playing, press Ctrl+I. Now you can edit the Title, 
Artist, Album and also apply the album art from an image file. VLC also 
allows for downloading album art automatically.

You can also add Lyrics to the song in the comments section. This way your 
media library looks well organized and easier to navigate. You can also do 
this to a video. Contrary to popular belief, just renaming a file doesn't make 
it easier to find in a media player. Do it and enjoy better music 
categorization!



Resume Videos from last position

By default, VLC doesn't resume the video from the point at which it was last 
stopped. If you want this feature, there are 2 ways out. One with an 
extension and one without.

With Extension
The extension called Remember Position does exactly the same task as you 
require. VLC extensions have the format .lua and to install an extension, just 
copy the file in the /lua/extensions directory. If you have VLC installed at 
D:\VLC Media Player, copy files to D:\VLC Media Player\lua\extensions and 
then restart VLC. To enable an extension, go to View>Extension Name.
Download It!

Without Extension
The same functionality can be achieved using Bookmarks. When the 
song/video is playing, just press Ctrl+B to create a bookmark at that 
position. The same way, you can bookmark where you left the video. As 
easy as pie!

Please Note that once you change the path of the video being played, the 
Bookmarks will automatically be deleted, so take care!

http://addons.videolan.org/CONTENT/content-files/157838-mempos.lua
http://addons.videolan.org/CONTENT/content-files/157838-mempos.lua


That's All Folks!

In this initial edition of the book, I've not covered streaming using VLC as I 
did not have the required apparatus. If there is any kind of demand to cover
it up, I'd definitely do it in the forthcoming editions

Thanks!
Siddharth Jha
www.twitter.com/thesidjway
www.facebook.com/thesidjway
www.last.fm/user/thesidjway

Please comment regarding this eBook. I've spent a lot of time designing 
and writing content for this eBook! Please feel free to drop in a mail to 
siddharthjha@outlook.com! Your feedback would be highly appreciated!

mailto:siddharthjha@outlook.com
http://www.last.fm/user/thesidjway
http://www.facebook.com/thesidjway
http://www.twitter.com/thesidjway

